Stanislav

шаблон vamshop1 по ссылке из оплаты отличается от демо vamshop1

Recommended Posts

Stanislav

Добрый день!

Несколько дней назад купил VamShop 1.96, скачал файлы магазина по ссылке на странице оплаты, установил, все хорошо. После установки, выбрал в админке шаблон vamshop1 он мне больше нравиться.  Этот шаблон отличается от демо VamShop 1.96 шаблон vamshop1 тем, что в демо шапка сайта там где лого -  на всю длину экрана, а у меня шапка сайта ограничена как я понял. Такое может быть, что разные vamshop1  в демо и в скаченных файлах? Как исправить? нравиться как в демо

 

Share this post


Link to post
Share on other sites
support
1 час назад, Stanislav сказал:

Добрый день!

Несколько дней назад купил VamShop 1.96, скачал файлы магазина по ссылке на странице оплаты, установил, все хорошо. После установки, выбрал в админке шаблон vamshop1 он мне больше нравиться.  Этот шаблон отличается от демо VamShop 1.96 шаблон vamshop1 тем, что в демо шапка сайта там где лого -  на всю длину экрана, а у меня шапка сайта ограничена как я понял. Такое может быть, что разные vamshop1  в демо и в скаченных файлах? Как исправить? нравиться как в демо

 

Здравствуйте!

Да, в текущем коде шаблон сделан "резиновым", но обновление ещё не вышло и поэтому архивы не обновлены.

Вот попробуйте взять эти файлы:

/templates/vamshop1/stylesheet.css

/templates/vamshop1/index.html

Что б шаблон тоже у Вас стал резиновым.

index.html

stylesheet.css

Share this post


Link to post
Share on other sites
support

Вот вышла 1.97 версия.

Можно скачать обновление и установить к себе в магазин - 

 

Шаблон vamshop1 станет резиновым.

4 часа назад, Stanislav сказал:

Добрый день!

 

 

Share this post


Link to post
Share on other sites
Stanislav

спасибо!

Share this post


Link to post
Share on other sites
support
6 минут назад, Stanislav сказал:

спасибо!

Не за что.

Скачайте, попробуйте.

По идее, всё должно быть нормально.

Share this post


Link to post
Share on other sites
Stanislav

обновления из админ панели ставятся как-то или другой способ?

а, то есть просто в корень сайта все скопировать, а SQL файл в базу закинуть, разобрался

Share this post


Link to post
Share on other sites
support
11 минут назад, Stanislav сказал:

обновления из админ панели ставятся как-то или другой способ?

а, то есть просто в корень сайта все скопировать, а SQL файл в базу закинуть, разобрался

В VamShop 1 обновления ставятся вручную, просто файлы перепишите и всё, из папки patch в корневую папку Вашего магазина.

В 1.97 sql файлов нет, т.е. база данных не обновлялась.

Если у Вас сейчас 1.96 верси, тоскачиваете 1.97 обновление по ссылке, что я выше написал и просто переписываете файлы, всё.

Share this post


Link to post
Share on other sites
Stanislav

после установки обновления у меня магазин лег. с бекапа востановить не получилось. посколько магазин был пустой, то я снес всю базу и удалил полностью корневую папку на сервере. Потом опять стал ставить с нуля дистрибутив, все поставилось вроде бы хорошо, 4 шага нормально, но теперь у меня после установки дистрибутива захожу на домен, там см ниже, вообще не понятно что делать

Not Found

The requested URL /redirector.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

piopushka.ru

 

а походу не все из архива скопировалось, сейчас еще раз попробую дистрибутив распаковать ))

 

да, дистрибутив встал нормально, это хорошо. обновление ставить не буду тогда пока что, подожду 

Share this post


Link to post
Share on other sites
support
1 час назад, Stanislav сказал:

да, дистрибутив встал нормально, это хорошо. обновление ставить не буду тогда пока что, подожду 

Вообще не должно было ничего лечь, если у Вас 1.96 версия была.

Раз у Вас ещё не рабочий магазин, я Вам советую тогда вообще 1.97 поставить сразу.

Нужно тогда выяснить, почему не работает после обновелния.

В ошибке пишет, что нет файла /redirector.php в корневой папке магазина.

Share this post


Link to post
Share on other sites
Stanislav

поставил полную версию 1.97, заработал.

есть проблема не создаются новые категории, статьи и не делается бекап, какая то замарочка на стороне хостера?

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit - prohibited by configuration (/home/u294830/piopushka.ru/www/admin/sxd/backup.php:81)

Share this post


Link to post
Share on other sites
support
6 часов назад, Stanislav сказал:

полную

А что пишет, какая-то ошибка при создании категорий или что?!

У меня всё работает, к примеру.

По поводу backup, закомментируйте (или удалите) 81 строку в файле /admin/sxd/backup.php

Share this post


Link to post
Share on other sites
Stanislav

создал раздел Статьи articles.html
в разделе Статьи создал статью test-statia-1.html

эти ссылки появились в блоках Статьи и Новые статьи на главной.

сама статья открывается test-statia-1.html

а категория Статьи articles.html выдает 500 ошибку

Страница недоступна

Сайт piopushka.ru пока не может обработать этот запрос.

HTTP ERROR 500

закомментировал 81 строку в файле /admin/sxd/backup.php , появилось окно программы Sypex Dumper 2.0.11.  Нажимаю на кнопку Сохранить, появяется окно с надписью 

Warning: set_time_limit() [<a href='function.set-time-limit'>function.set-time-limit</a>]: Cannot set time limit - prohibited by configuration (/home/u294830/piopushka.ru/www/admin/sxd/index.php:81)

 

 

 

Share this post


Link to post
Share on other sites
support

Надо не сохранить нажимать, а правую нижнюю кнопку - Выполнить.

У Вас в корневой папке есть файл .htaccess, он не пустой?!

Ради эксперимента, попробуйте тоже самое прделать в демке http://demo.vamshop.ru

Я имею в виду статьи.

В демке работает?!

20 минут назад, Stanislav сказал:

Сайт piopushka.ru пока не может обработать этот запрос.

 

 

Share this post


Link to post
Share on other sites
Stanislav

в демке да работает и категория и статья создались, по ссылкам категория Статьи и сама статься доступны.

по бекапу вот какая картина уже 5 минут ничего не происходит см картинку

19.01.png

Warning: set_time_limit() [<a href='function.set-time-limit'>function.set-time-limit</a>]: Cannot set time limit - prohibited by configuration (/home/u294830/piopushka.ru/www/admin/sxd/index.php:81)

Share this post


Link to post
Share on other sites
support
10 минут назад, Stanislav сказал:

в демке да работает и категория и статья создались, по ссылкам категория Статьи и сама статься доступны.

 

В демке backup отключён, что б не баловилсь.

В общем, я наугад не могу сказать, что у Вас.

Присылайте в личку ссылку на магазин, доступ на ftp, доступ в админку.

Посмотрю.

Share this post


Link to post
Share on other sites
Stanislav

отправил в личку, спасибо

Share this post


Link to post
Share on other sites
support
38 минут назад, Stanislav сказал:

отправил в личку, спасибо

Вижу.

Не с этими данными ни в админку не смог зайти, ни на ftp подключиться.

Share this post


Link to post
Share on other sites
Stanislav

сорри, наверное из за того, что сам сижу в админке не пускает, разлогинился

ftp пароль  сменил на новый, отправил Вам в личку, он активируется в течении 30 минут хостер предупредил

Share this post


Link to post
Share on other sites
support
21 минуту назад, Stanislav сказал:

сорри, наверное из за того, что сам сижу в админке не пускает, разлогинился

ftp пароль  сменил на новый, отправил Вам в личку, он активируется в течении 30 минут хостер предупредил

Вероятнее всего, что проблема в слишком старой php версии.

У Вас php 5.3

В настройках хостинга в панели мастерхост, насколько я помню Вы можете выбрать версию php.

Выберите 7.0 или 7.1 или 5.6 минимум, если 7 версии нет.

Что б точно узнать текст ошибки, когда в браузере просто 500 ошибка, это надо смотреть error log файл веб-сервера.

Опять же, по идее, в панели где-то в панели должна быть ссылка на лог файлы.

На ftp вроде нигде нет папки logs

Share this post


Link to post
Share on other sites
Stanislav

error log файл отправил в личку

у меня второй сайт на vamshop работает с 2012г. версия 1.67 не обновлялся ни разу т.к. много правок, если поменяю php 5.3 на более свежую, второй сайт у меня как поведет себя?

да, на Мастерхосте нашел можно поменять, сейчас

Текущая версия PHP: 5.3
Текущая версия MySQL: 5.6

можно поменять на 5.4, 5.5, 5.6, 7.0 или 7.1

вопрос по второму сайту тогда, что с ним делать

Share this post


Link to post
Share on other sites
support
36 минут назад, Stanislav сказал:

error log файл отправил в личку

у меня второй сайт на vamshop работает с 2012г. версия 1.67 не обновлялся ни разу т.к. много правок, если поменяю php 5.3 на более свежую, второй сайт у меня как поведет себя?

да, на Мастерхосте нашел можно поменять, сейчас

Текущая версия PHP: 5.3
Текущая версия MySQL: 5.6

можно поменять на 5.4, 5.5, 5.6, 7.0 или 7.1

вопрос по второму сайту тогда, что с ним делать

Всё, исправил чуть код, что б работало и на старой версии.

Не надо ничего переключать, проверьте, сейчас должно работать.

Резервное копирование тоже работает.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now