Sign in to follow this  
support

Как запустить текущую версию VamShop на старой версии PHP?

Recommended Posts

support

Минимальная старая версия php, на которой можно запустить VamShop с небольшими правками - php 5.2.

Что б запустился VamShop на php 5.2, php 5.3, php 5.4, нужно:

1. Отключить поддержку composer, отредактировав файлы /includes/application_top.php и /admin/includes/applicaton_top.php

Удалив строку:

// include composer autoload
  require(DIR_FS_CATALOG . '/vendor/autoload.php');

2. Отключить минификацию html-кода, в файле /includes/classes/vam_template.php поменяйте:

$this->loadFilter('output', 'minify_html');

на:

//$this->loadFilter('output', 'minify_html');

Всё, с таким правками VamShop запустится на старых версиях php.

Но я не рекомендую использовать старые версии php, как минимум выбирайте php 7

На php 7 Ваш сайт будет работать намного быстрее.

Share this post


Link to post
Share on other sites
Sign in to follow this